Last Year: The Nightmare system requirements

LYTN

Last Year: The Nightmare System Requirements (minimum)

  • CPU: Intel Pentium G4500 / AMD A10-7870K
  • CPU SPEED: Info
  • RAM: 6 GB
  • OS: Windows 7
  • VIDEO CARD: GeForce GT 630 or equivalent
  • PIXEL SHADERS: 5.0
  • VERTEX SHADERS: 5.0
  • FREE DISK SPACE: 20 GB
  • DEDICATED VIDEO RAM: 1024 MB

Last Year: The Nightmare Recommended Requirements

  • CPU: Intel Core i3-4170 / AMD Ryzen 3 1300X
  • CPU SPEED: Info
  • RAM: 8 GB
  • OS: Windows 7
  • VIDEO CARD: GeForce GTX 760 or equivalent
  • PIXEL SHADERS: 5.0
  • VERTEX SHADERS: 5.0
  • FREE DISK SPACE: 20 GB
  • DEDICATED VIDEO RAM: 2048 MB

Can my PC run Last Year: The Nightmare

LYTN copy link to current configuration
Select your hardware components to find out how the game will run on your PC

CPU

Your browser is so ancient that we could not communicate with it in the same language

minimum: AMD A10-7870K Intel Pentium G4500 @ 3.50GHz recommended: AMD Ryzen 3 1300X
your Processor:
Select CPU model

Video Card

Try updating your browser if you want to know the system requirements of Last Year: The Nightmare

minimum: recommended: GeForce GTX 760
your Videocard:
Select Videocard model

RAM

Need update your browser

minimum: 6 Gb recommended: 8 Gb
your Memory:
Set RAM value
Will not run Will run but most likely will be not playable Minimum to play the game Comfortable gameplay
Your hardware

Games with the same requirements

there is no games for comparison

Games with similar system requirements (+ 5% to requirements)

there is no games for comparison